19 lines
736 B
Nix
19 lines
736 B
Nix
{
|
|
## This file passes in your secrets/passwords into your system's `configuration.nix` file.
|
|
## Add "secrets.nix" to your `.gitignore` file and hash all passwords and secrets for best practices.
|
|
|
|
## Replace with your system username.
|
|
systemUsername = "sarracenia_purpurea";
|
|
|
|
## Replace with your domain name.
|
|
## hostName = "mydomain.tld";
|
|
hostName = "spaghetticode";
|
|
|
|
## Manually hash password with `mkpasswd` then replace below.
|
|
##
|
|
## For example after hashing your password: "correcthorsebatterystaple" with `mkpasswd`
|
|
## it becomes something like: hashedPassword = "$y$j9T$JiToouWQ2LIo3Pz1/b1S8.$tpNSJnokDfyfsdVgSboVk/STNnIf7R42HJToIFr1Gq7".
|
|
##
|
|
hashedPassword = "replace_this_with_your_hashed_password";
|
|
}
|